System requirements and supported browsers

This topic lists browsers and versions tested with the Admin Portal and the Centrify Browser Extension.

Admin Portal supported browsers

This version of Privileged Access Service has been tested with the following browsers:

Browser

Version

Internet Explorer

Version 11 on Windows: 2019, 2016, 2012, 2008 servers and Windows 7, and Windows 10. Note: Microsoft .NET Framework 4.8 or later is required for Internet Explorer. Additionally, computers must have Microsoft Installer 3.1 or later to install the Centrify Browser Extension

Microsoft Edge Chromium

latest version available at release

Mozilla Firefox

latest version available at release

Google Chrome

latest version available at release

For silent authentication to work correctly, some web browsers need additional configuration (see How to configure browsers for silent authentication) or a browser extension (see How to install the Centrify Privileged Access Service Browser Extension).