Verify prerequisites

Before installing the Windows agent, verify the computer on which you plan to install meets the following requirements:

  • The computer is running a supported Windows operating system version.
  • The computer is joined to Active Directory.
  • The computer has sufficient processing power, memory, and disk space for the agent to use.
  • The computer has the .NET Framework, version 4.5.2 or later.
  • The computer has Windows Installer version 3.1, or later.

If you are installing interactively using the setup program, the setup program can check that the local computer meets these requirements and install any missing software. If you are installing silently from the command line or by using a Group Policy Object, you should verify the computers where you plan to install meet these requirements. If you are installing silently and a computer does not meet these requirements, the installation will fail.