Compatibility for CentrifyDC-nis package

If you are upgrading the core agent packages and have the CentrifyDC-nis package installed, you should also upgrade the CentrifyDC-nis package. The CentrifyDC‑nis package must have the same major version number as the core agent packages. The version number for the CentrifyDC-nis package should never be higher than the version number of the core agent packages.

Note that on some platforms, the adnisd package might prevent the ypbind service from starting properly because of the order in which services are started. For example, if ypbind is configured to start before the adnisd service, the bind will fail. This issue does not occur if you are installing new packages. However, to prevent unintended changes to the existing startup sequence during an upgrade, upgrading the adnisd package will not modify your existing startup configuration. You can manually correct the startup sequence after an upgrade by manually running the chkconfig script. For example, run the following command after the adnisd upgrade:

chkconfig adnisd on