Access control and privilege management compatibility

You can upgrade to Centrify Authentication Service, Privilege Elevation Service, and Audit & Monitoring Service—with Access Manager, version 5.1.x or later—to manage zones and agents (adclient) from version 3.x, 4.x, or 5.x. If you have agents from version 2.x, you must manage them using a console from version 4.x or earlier. If you use an older version of the console, you cannot take advantage of any features or enhancements introduced in newer versions of the console. If you upgrade to the latest release, you can continue to manage all of your currently deployed agents but must upgrade those agents to take full advantage of any new features.

You must upgrade UNIX, Linux, or Mac agents to 5.0 or later to use hierarchical zones. If you have zones from a previous release of Centrify software, you can use admigrate to convert those zones to hierarchical zones.

To manage Windows computers with Access Manager, the Centrify Windows agent must be version 3.0 or later.