DB2 and Centrify plug-in compatibility

Starting with DB2 release 10.5.4, DB2 does not allow security plug-ins to fork a process to authenticate DB2 users. To support this behavior, the Centrify plug-ins starting with Centrify for DB2 5.2.3 use the CentrifyDC service to authenticate Active Directory and local users.

If your environment contains DB2 10.5.4 or later:

  • Only Centrify for DB2 5.2.3 or later plug-ins are supported, and
  • Before you install Centrify for DB2, you must install the Server Suite 2015.1 or later agent (that is, agent version 5.2.3+) on each DB2 server, and
  • You must ensure that the agent (that is, the centrifydc service) is running on each DB2 server.