Centrify® PuTTY 5.7.0 (Release 2020) Release Notes

© 2004-2020 Centrify Corporation.

This software is protected by international copyright laws.

All Rights Reserved.

Table of Contents

1.      About This Release. 1

2.      Feature Changes. 2

2.1.       Feature Changes in Centrify PuTTY 5.7.0. 2

2.2.       Feature Changes in Centrify PuTTY 5.6.0. 2

3.      Bugs Fixed. 2

3.1.       Bugs Fixed in Centrify PuTTY 5.7.0. 2

3.2.       Bugs Fixed in Centrify PuTTY 5.6.0. 2

4.      Known Issues. 2

5.      Additional Information and Support 3

 

1.     About This Release

 

PuTTY is a popular open-source client on Windows and UNIX-based computers that provides access to remote machines using well-known network protocols such as Telnet, SSH, rlogin and raw TCP. However, it does not support Kerberos authentication.

 

Centrify has enhanced PuTTY so that user authentication can be accomplished using Kerberos before establishing a remote connection. The Centrify-enhanced version of PuTTY takes advantage of the Kerberos environment that the Centrify DirectControl agent sets up automatically on managed UNIX and Linux computers. By using the Centrify PuTTY client to access Centrify-managed computer, you gain the benefits of centralized authentication and password policy enforcement using a secure and well-established authentication infrastructure.

 

Centrify PuTTY is currently integrated with open source PuTTY version 0.73.

 

The Centrify Zero Trust Privilege Services and PuTTY release notes and documents are available online at http://docs.centrify.com.

 

Centrify software is protected by U.S. Patents 7,591,005; 8,024,360; 8,321,523; 9,015,103; 9,112,846; 9,197,670; 9,378,391 and 9,442,962. (Ref: CS-44575)

2.     Feature Changes

2.1.          Feature Changes in Centrify PuTTY 5.7.0

 

·         Centrify PuTTY is upgraded based on PuTTY v0.73 from v0.71. (Ref: CS-48152)

-   This includes several security fixes, e.g. CVE-2019-17067, CVE-2019-17068, and CVE-2019-17069. For details, please refer to https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html.

2.2.          Feature Changes in Centrify PuTTY 5.6.0

 

·         Centrify PuTTY is upgraded based on PuTTY v0.71 from v0.70. (Ref: CS-47817)

-    This includes several security fixes, e.g. CVE-2019-9894, and CVE-2019-9895, CVE-2019-9896, CVE-2019-9897, and CVE-2019-9898. For details, please refer to https://www.chiark.greenend.org.uk/~sgtatham/putty/changes.html.

3.     Bugs Fixed

3.1.          Bugs Fixed in Centrify PuTTY 5.7.0

 

·         N/A

3.2.          Bugs Fixed in Centrify PuTTY 5.6.0

 

·         N/A

4.     Known Issues

 

·         puttytel does not support Kerberos authentication. 

·         If you specify Alternate Kerberos credentials on the SSH > Kerberos properties page, you will always be prompted for a password. This will happen even if you choose to remember the password when first prompted for it.

5.     Additional Information and Support

 

In addition to the documentation provided with this package, you can find the answers to common questions and information about any general or platform-specific known limitations as well as tips and suggestions from the Centrify Knowledge Base.

 

The Centrify Resources web site provides access to a wide range of information including analyst report, best practice brief, case study, datasheet, ebook, white papers, etc., that may help you optimize your use of Centrify products. For more information, see the Centrify Resources web site:

www.centrify.com/resources

You can also contact Centrify Support directly with your questions through the Centrify Web site, by email, or by telephone. To contact Centrify Support or to get help with installing or using this software, send email to support@centrify.com or call 1-669-444-5200, option 2. For information about purchasing or evaluating Centrify products, send email to info@centrify.com.